窗外

继续升级

上次尝试升级这个VM的OS,但是由于当时网络状况不稳定,失败了,于是就放在那里没管了一段时间。最近老有一堆提示说有安全补丁要打,操作系统需要升级什么的,看着心烦,于是昨天晚上就又尝试升级了一次。这次网络比较稳定,OS很顺利地就升到Ubuntu 14.04了。

但是,升级后apache遇到一些问题,原来的apache配置文件似乎不起作用了,网站无法访问。查了些资料,原来是apache 2.4的配置文件和语法有些变化,导致原来的配置文件不起作用或者有语法错误,所以配置失效了。比如apache 2.2的网站配置文件,在/etc/apache2/sites-available/目录里是没有后缀的,apache 2.4要求必须有后缀.conf等等。这篇问答里的答案,提供了不少有用的信息:403 error after upgrading to apache2.4

不由得想起有一次和人讨论为什么近来建在iis上的网站越来越多,我当时说,系统容易升级肯定是其中一个原因。我这只是个很小的Linux VM,除了跑AMP之外,几乎没有其他的应用和服务。而跑在AMP上的,也是相当成熟的Wordpress,可是升级一下系统,也会遇到一些细节的问题,对于那些复杂一些的网站,升级的难度可想而知了。所以,像Stackoverflow这样的大站,能够始终运行在微软最新的产品和平台上,就显得非常牛逼了。

Tags

Leave a Reply

Your email address will not be published. Required fields are marked *